Skip to main content
InSource Solutions

Understanding common InTouch license errors

InSource_Logo_Transparent (1).png problem-solving.jpg
SOLVER

                 

Description

 

 

Author

Dillon Perera

Publish Date  

Applies to Software

InTouch

Applies to Version

 

Applies to System/Module

 

Article Version

 

************************************************************************************************************************************************************

 

Common Error Messages:

Edit section

Message #1: An error occurred reading the Feature Line ‘InTouch_’ in the … (Return Code: -31)

error-31.jpg

Cause:

This occurs if InTouch finds that the system clock has potentially been tampered with.​

Common Solution:

Check the system clock on the computer and ensure it is set to the correct date and time.

Message #2: The License File … was located, but the Feature Line ‘InTouch_’ could not be found inside of it.

InTouch_CouldNotBeFound.jpg

Cause:

InTouch licenses can be purchased to run as either classic standalone applications, or as an application which is part of a galaxy.  This error occurs if you are trying to run in a mode your license does not allow​

Common Solution:

Within InTouch WindowMaker, under Special > Application Type, toggle whether or not your application is set as an InTouch View Application.​

Message #3: The Feature Line ‘InTouch_’ is not enabled for use on this computer.

InTouch_NotEnabled.jpg

Cause:

This particular license was issued with a hardware dongle which InTouch cannot find on the system.​

Common Solutions:

- Ensure that the hardware dongle is plugged into a working port on the computer and that it is the correct dongle for this license.
- Ensure no other license dongles are plugged into the computer at the same time.

 

Message #4: The Feature Line ‘InTouch_’ is not the right version...

InTouch_NotRightVersion.jpg

Cause:

The license file being installed is not meant to be used with the currently installed version of InTouch.  License files are tied to specific versions of InTouch and cannot be used across all versions.​

Common Solution:

Uninstall the current installation of InTouch and install the correct version which the license enables.

Message #5: License does not enable WindowMaker - exiting

LicenseDoesNotEnable.jpg

Cause:

The license file installed is a runtime license meaning only WindowViewer can be run, or if trying to run WindowViewer this may occur if you are using an InTouch for System Platform License.

Common Solutions:

- Install a development license on the system to enable the WindowMaker functionality.
- Within InTouch WindowMaker, under Special > Application Type, toggle whether or not your application is set as an InTouch View Application.