Skip to main content
InSource KnowledgeCenter

TN WW233 Prerequisite Updates for Microsoft .NET Framework 4.7.2

 

Description

This article from InSource Solutions discusses the prerequisite Microsoft Updates required to install Microsoft .NET Framework 4.7.2.

  • Author: Daniel London
  • Published: 05/22/2019
  • Applies to: System Platform 2017, InTouch Edge HMI, Windows Server 2012 R2, Windows 8.1

 

Details

Newer versions of Wonderware (beginning with 2017 Update 2), require Microsoft .NET Framework 4.7.2 to be installed. The installation media includes this as part of the prerequisite install, but it will fail to load the .NET Framework if certain Microsoft updates are not present on the system. This article discusses how to install the Microsoft Updates that are required to install .NET 4.7.2.

Further Reading and Install Instructions:

https://www.microsoft.com/en-us/download/details.aspx?id=42334

The updates required for the install are:

KB2919355

KB2932046

KB2959977

KB2937592

KB2938439

KB2934018

NOTE:

If you are using Windows Server 2012 R2 as the operating system, KB2919422 must be installed before KB2919355

Further Reading and Install Instructions:

https://www.microsoft.com/en-ie/download/details.aspx?id=42153

Install Instructions.JPG