Skip to main content
InSource KnowledgeCenter

TN WW117 Wonderware Tech Support Info Tool

insource logo large.jpg

 

Description

This easy-to-use tool which can be downloaded from the Wonderware Support site at www.wonderware.com/support allows you to gather the System Information, Registry information, Product information, Wonderware Logger and Windows Events information on your local machine for troubleshooting.

 

  • Author: Peter Farrell
  • Published: 6/30/2015
  • Applies to: Info Tool 1.0.0

 

 

Details

You can retrieve and store multiple machine information about your system within a single file.

 

System information (Example: Operating system, processor, display configuration, disk space, all the running process, all the installed services, environment variables, network adaptors) 


Wonderware products (Versions, Install locations and all the file information) 


Other Products (Product name, version and install location) 


Common Component and Global Assembly Cache information 


Wonderware product registry information 


ArchestrA user information 


Wonderware Logger information 


Windows Event information

 

Installing The Wonderware Tech Support Info Tool


Unzip the product into a temporary folder. 


Run the WonderwareTSInfoToolSetup.msi.


The utility is installed by default under ..\Program Files\Wonderware\WonderwareTSInfoTool folder.


For 64-bit operating systems the default is ..\Program Files (x86)\Wonderware\WonderwareTSInfoTool. 


Run the Wonderware TS Info Tool.exe file when you want to use the utility. 


To Uninstall


Uninstall the tool using Control Panel > Add/ Remove Programs.

 

Compatibility


The Wonderware Technical Support Info tool is supported on

Windows XP SP3 


Windows Server 2003 SP2 


Windows Server 2008 R2 SP1 (64-bit) 


Other Windows Operating Systems such as Vista/Windows 7 were not tested but should be compatible. 

 

Using the Wonderware Tech Support Info Tool

 

Open the Wonderware Tech Support Info Tool by clicking Start -> All Programs -> Wonderware -> WonderwareTSInfoTool.


You can also open the tool by double-clicking Wonderware TS Info Tool.exe.


Open the tool and click the Retrieve Wonderware Information button. 


Click Information Retrieval Options and then click OK.


• Information appears under the relevant tabs according to your selected options.


• You can save your collected information as an xml file by clicking File -> Save on the main menu.


• You can generate a report by clicking Report -> Generate Report. Both the xml file and the html file can then be emailed to Tech Support for further investigation. 


Details of the User Interface


This tool has the following main tabs: System Information and Notes.


You can retrieve the system and other information. You can also retrieve and store multiple machine information within a single file.


WWTSInfo_Image_001.png

 

By default the local machine appears under Machines item in the System Information tab.


1. In the Machine Usage field of the main User Interface, type a description of the machine usage/role in your application topology. For example: InTouch node, GR Node, InTouch TSE Server Node) 


2. In the Additional System Info field, add any specific machine information that might be missed by the tool. 


3. Click the Retrieve Wonderware Information button. The Information Retrieval Options dialog box appears. 


WWTSInfo_Image_002.png


4. Select your retrieval options and click OK. 


It can take several minutes to gather all the information from the selected system.


After the tool completes the information retrieval, you can see all the information populated under the tabs listed in the following sections.


This tool retrieves information only from the node on which it is installed (local).


Main Menu Commands


File -> New: All earlier information retrieved if any is cleared and tool is now ready for retrieving new information from the local machine. 


File -> Open: A previously saved xml file using this tool can opened using this menu item. 


File -> Save: Information retrieved on this PC can be saved as xml file on a specified location. You can retrieve and store multiple machine information within a single file. 


File -> Import: An xml file from another machine can be imported using this menu item. In this case both the retrieved information from local machine as well as from another machine is populated under each tab. 


File -> Export file version information: File List information populated under Product Information tab can be stored with the default filename C:\filelist.csv. 


File -> Exit: Close the Tool. 


Report -> Generate Report: An html file with default name is created and can be saved on specified folder on the PC. All the information retrieved using the Retrieve Wonderware Information button is stored in this report in html format. 


Help -> Help Contents: Opens the .chm help file for this tool. You can also press F1 to see the Help file. 


Help -> About